Top/Ruby/bundlerを古いバージョンに切り替える

Ruby/bundlerを古いバージョンに切り替える

bundle install しようとした際に以下のエラーが出ることがある。

Bundler could not find compatible versions for gem "bundler":
 In Gemfile:
   bundler (< 2.0.0, >= 1.5.0)

 Current Bundler version:
   bundler (2.1.4)

bundleのバージョンの現状が2.xで、必要なバージョンは1.xになる。
以下のようにして1.xを共存インストールし、切り替えて使う。

インストール可能なバージョンを確認する

gem search ^bundler$ --all

特定のバージョンをインストールする

gem install bundler -v 1.17.3

インストール状態を確認する

gem list bundler

インストールしたバージョンを確認する

bundle _1.17.3_ -v 

デフォルトバージョンの確認

bundle -v 

バージョンを指定して実行する

bundle _1.17.3_ install
このページを共有:
  • このページをはてなブックマークに追加 このページを含むはてなブックマーク
  • このページをlivedoor クリップに追加 このページを含むlivedoor クリップ
  • このページをYahoo!ブックマークに追加
  • このページを@niftyクリップに追加
  • このページをdel.icio.usに追加
  • このページをGoogleブックマークに追加

このページのURL:

ページ新規作成

新しいページはこちらから投稿できます。

TOP